Sound System

This forum discusses anything to do with your In Car Entertainment requirements such as. Stereo's, TV screens, Speakers, Navigation Systems, etc

Moderators: IMC, Club Staff

Post Reply
User avatar
bradicus
Apprentice
Posts: 97
Joined: Sun Nov 22, 2015 11:07 pm
Location: Adelaide
Sound System

Post by bradicus » Thu Dec 03, 2015 2:35 pm

Installed a sound system in my fto, 2 amps, sub, 4 new speakers, double din head unit.

Have a 4 way amp for the speakers, some professional that does this for living was telling me you should still run 2 speakers off the head unit. So I did that with the front speakers, lets just say it sounds a lot better when the front speakers are running off the amp. Dont know why he gave me that advice? Will upload some pics later

User avatar
bradicus
Apprentice
Posts: 97
Joined: Sun Nov 22, 2015 11:07 pm
Location: Adelaide
Re: Sound System

Post by bradicus » Thu Dec 03, 2015 11:59 pm

Image

Image

User avatar
kiz
SA Coordinator
Posts: 2175
Joined: Wed Nov 09, 2011 10:09 pm
Location: Adelaide, South Australia
Re: Sound System

Post by kiz » Fri Dec 04, 2015 12:33 pm

Ideally you'd want to run everything off amps. Going to get better power and quality. Mono block for your sub and either 2x 2channels or 1x 4 channel for the speakers
There are two types of people on forums; those that give helpful advice, and the others

1998 Mitsubishi FTO GPVR AERO ;)

User avatar
silverGPX
9.5"
Posts: 6719
Joined: Tue Oct 13, 2009 5:00 pm
Re: Sound System

Post by silverGPX » Fri Dec 04, 2015 3:42 pm

He probably meant run the rears off the head unit and bridge the fronts for more power. This is Without going into active setups with components

User avatar
destinationtoby
Broke it
Posts: 3503
Joined: Sat Nov 24, 2012 11:05 pm
Location: mid north coast
Re: Sound System

Post by destinationtoby » Fri Dec 04, 2015 10:00 pm

Cool, I really like the pink.
Because nothing is faster than a p plater in a commodore.....
except maybe a p plater on a unicorn
FTOcrazy273 wrote: Destinationtoby probably has one of THE best FTO's on the forum I never get tired of looking at his pics! Good work mate!

User avatar
bradicus
Apprentice
Posts: 97
Joined: Sun Nov 22, 2015 11:07 pm
Location: Adelaide
Re: Sound System

Post by bradicus » Sat Dec 05, 2015 4:56 am

cheers haha, its red though

User avatar
PHIL069
Oldtimer
Posts: 4709
Joined: Sun Sep 20, 2009 5:00 pm
Location: Central Coast > South Australia
Re: Sound System

Post by PHIL069 » Sat Dec 05, 2015 10:03 am

Yeah, that interior looks good on your car...
mikeey01nzl wrote:Hats off to you too Phil for spending so much time on the phone trying to help someone out, your a top man and only a few would've spent so much time. well done! :salut:
Daniel2019 wrote:Come on phil, we bonded at the bonfire, lets be honest here...me and phil are besties now... :lol:
ImageImageImage

User avatar
Vectose
Oldtimer
Posts: 3821
Joined: Sun Nov 28, 2010 8:45 pm
Location: Newcastle
Re: Sound System

Post by Vectose » Sat Dec 05, 2015 11:34 am

PHIL069 wrote:Yeah, that interior looks good on your car...
:lol:
Bennoz wrote:
Technikhaus wrote:What is in said Bens big penis by the way?
A whoooole lot 'o jism 8)

User avatar
bradicus
Apprentice
Posts: 97
Joined: Sun Nov 22, 2015 11:07 pm
Location: Adelaide
Re: Sound System

Post by bradicus » Sat Dec 05, 2015 3:53 pm

The lighting is off this is the actual color

Image


Post Reply