1300rpm idle in drive after ecu reset and radiator swap

Got a problem with your FTO? ask about it here

Moderators: IMC, Club Staff

Post Reply
mivecy0
Newbie
Newbie
Posts: 5
Joined: Sat Jul 01, 2017 4:34 pm
1300rpm idle in drive after ecu reset and radiator swap

Post by mivecy0 » Sat Jul 01, 2017 6:53 pm

Not sure if this'll be the first and last post I make before lugging this car to a mechanic, then auto wreckers

A few days ago my radiator cracked driving up the driveway when going to detail and clean the car. I managed to find a replacement one that day and replaced and filled with coolant (or so I thought), though I'm not sure if I burped the air bubbles fully in this procedure as I was losing my sh*t, and forgot that the thermo doesn't open until operating temp, and just filled with coolant.... *gulps* (edit: was filled with coolant til coolant was up to bottom of nozzle so I could start the car for 30 sec, then refilled til same, did this twice)

I drove the car that evening with erratic as hell idles. Getting home that evening to realize why. Luckily I didn't get any overheating or dash lights come up, and when I got home to refill coolant in the proper procedure the following morning, it only took in like 1/2 L to 1L more coolant.... making me think that there must have still been quite a bit in the block or something still when I installed the new radiator.

Though now the car is idling at 1,2-1,300 in drive, and 3000rpm in park after driving around for 30 mins

Is this just ECU hunting still or perhaps have I broken something in that drive that night?....

Signs from my exhaust are indicating that the car is running rich, not smelling any sweet smells or anything

Just feels like the gearbox is trying to jump out of the car with every downshift, kinda displaying ISC type errors

edit; before this radiator went the idles were nice and the car was driving normally, now the car literally drives uphills with my foot off the accelerator...

Any advice here?

User avatar
Vectose
Oldtimer
Posts: 3838
Joined: Sun Nov 28, 2010 8:45 pm
Location: Newcastle
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by Vectose » Sat Jul 01, 2017 7:29 pm

Sounds like you've got a vacuum leak if idling at 3k.

Check around the intake manifold for any loose vacuum hoses.
Bennoz wrote:
Technikhaus wrote:What is in said Bens big penis by the way?
A whoooole lot 'o jism 8)

User avatar
getonit
Apprentice
Posts: 76
Joined: Fri Sep 11, 2015 1:26 pm
Location: In Toukley, with ya mum.
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by getonit » Sat Jul 01, 2017 7:29 pm

Auto or manual?
Image

User avatar
Vectose
Oldtimer
Posts: 3838
Joined: Sun Nov 28, 2010 8:45 pm
Location: Newcastle
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by Vectose » Sat Jul 01, 2017 7:31 pm

getonit wrote:Auto or manual?
Auto. He said in park mate.
Bennoz wrote:
Technikhaus wrote:What is in said Bens big penis by the way?
A whoooole lot 'o jism 8)

User avatar
getonit
Apprentice
Posts: 76
Joined: Fri Sep 11, 2015 1:26 pm
Location: In Toukley, with ya mum.
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by getonit » Sat Jul 01, 2017 7:32 pm

Derrrrr
Image

mivecy0
Newbie
Newbie
Posts: 5
Joined: Sat Jul 01, 2017 4:34 pm
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by mivecy0 » Sat Jul 01, 2017 7:48 pm

should the PCV hose line going back to the inner motor be easy to remove without much force

edit: switched PCV hose for one that seals properly, makes no difference to idle :\
Last edited by mivecy0 on Sat Jul 01, 2017 8:45 pm, edited 1 time in total.

User avatar
Vectose
Oldtimer
Posts: 3838
Joined: Sun Nov 28, 2010 8:45 pm
Location: Newcastle
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by Vectose » Sat Jul 01, 2017 8:23 pm

inner motor?
Bennoz wrote:
Technikhaus wrote:What is in said Bens big penis by the way?
A whoooole lot 'o jism 8)

mivecy0
Newbie
Newbie
Posts: 5
Joined: Sat Jul 01, 2017 4:34 pm
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by mivecy0 » Sat Jul 01, 2017 8:48 pm

Vectose wrote:inner motor?
The intake manifold bank area

mivecy0
Newbie
Newbie
Posts: 5
Joined: Sat Jul 01, 2017 4:34 pm
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by mivecy0 » Sat Jul 01, 2017 10:29 pm

Thought I'd check the PCV valve itself just then and it seems to be allowing pressure both ways from crankcase and from rocker cover so I'll try replacing that and see if that solves it

If its not that would it likely be the inlet manifold gasket leaking air?

User avatar
silverGPX
9.5"
Posts: 6731
Joined: Tue Oct 13, 2009 5:00 pm
Re: 1300rpm idle in drive after ecu reset and radiator swap

Post by silverGPX » Wed Jul 05, 2017 10:03 pm

Accelerator cable snagged or not adjusted?


Post Reply